Das grosse Archiv mit 637
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
 
Sonstige (7) ->

Flexiblerer Einsatz des Autofilters
 
 
Aufgabe
Die Filtermöglichkeiten sind mit dem Autofilter normal nicht so flexibel wie mit dem Spezialfilter

Z.B. können pro Spalte nur zwei Bedingungen definiert werden
Außerdem ist die Verknüpfung von Bedingungen zwischen zwei
Spalten immer eine UND-Verknüpfung.

Diese Einschränkungen sollen aufgehoben werden.





Lösung
Die Liste steht in Spalte A bis C.

Beispielsweise sollen alle Datensätze angezeigt werden, bei denen in A "Eichel" steht
ODER in Spalte B 300.000

Ergänze eine Spalte "Kriterien".
Schreibe in D2 =ODER(A2="Eichel";B2=300000)
und kopiere die Formel nach unten.

Die Hilfsspalte D wird in den Filterbereich aufgenommen, dann filtere D nach WAHR.

In Spalte D können beliebige Formeln stehen, z.B. eine dreifache ODER-Bedingung
=ODER(A2="Schilli";A2="Schröder";A2="Fischer")

oder nach einem Teilstring, der in E1 steht:
=ISTZAHL(SUCHEN(E$1;A2))

Oder zum Ausblenden von Duplikaten
=ZÄHLENWENN(A$2:A2;A2)=1

Oder Filtern nach einem Monat der Datumsspalte
=Monat(C2)=8

u.v.m.

Jeweils wird Spalte D nur nach WAHR oder FALSCH gefiltert.

Durch die Hilfsspalte wird der Autofilter also noch flexibler als der Spezialfilter

 
    zurück


 
powered by telltarget