Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
 
Diagramme (1) ->

Zelle mit Formel aber ohne Inhalt im Diagramm ignorieren
 
 
Aufgabe
Unter Extras > Optionen > Diagramm kann man einstellen, dass leere Zellen im Diagramm ignoriert werden. Ab Excel 2007: Diagrammlinie rechts anklicken > Daten auswählen und da gibt es die Schaltfläche "Ausgeblendete und leere Zellen"
Wenn allerdings eine Formel in der Zelle steht funktioniert das nicht auch wenn sie 0 oder "" zurückgibt.

Es soll vermieden werden, daß "" als Ergebnis einer Formel im Diagramm als 0 (Null) interpretiert und gezeichnet wird.

Lösung
"" ist nicht leer! Leer ist Taste Entf. oder schreibe:
=WENN(A1="";NV();A1) oder =WENN(A1="";#NV;A1)
bzw. mit ...A1=0..., um Nullwerte auszublenden

#NV dokumentiert: komplett leer; -
Die ganzen #NV stören die Optik in der Tabelle. Die kannst Du bedingt weiß formatieren.

#NV ist kein Text sondern eine Fehlermeldung.
Markiere Spalte B, wenn das der Bereich ist
Format / bedingte Formatierung
Formel ist: =ISTNV(B1)
und weiße Schrift aussuchen


ACHTUNG:
Bei einem Liniendiagramm werden die Punkte mit NV() nur dann komplett gelöscht, wenn Sie am Anfang oder Ende der Datenreihe stehen. Sind sie zwischendrin wird eine interpolierte Linie zwischen dem vorherigen und folgenden Punkt gezeichnet
 
    zurück


 
powered by telltarget