Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
 
Mehrfachoperation (9) ->

Mehrfachoperation mit 3 Variablen durchführen
 
 
Aufgabe
Normalerweise kann MEHRFACHOPERATION nur mit 2 Variablen arbeiten und zwar einer Spalten- und einer Zeilenvariablen
Mit einem Trick läßt sich das aber auf drei (oder mehr) Variablen erweitern.

Beispiel:
Es soll der interne Zinsfuß einer Zahlungsreihe abhängig von den drei Größen
1. Anfangsinvestition
2. jährlich wiederkehrende Rückflüsse
3. Laufzeit
berechnet werden.

DOWNLOAD





Lösung
Die Pointe ist das die zwei Variablen Investition und Rückflüsse in einer
Zelle (D13) semikolongetrennt eingegeben werden.
In D14 steht die Laufzeit.

In A17:A32 stehen die Perioden 0 bis 15.

In B17 steht
=LINKS(D13;-1+FINDEN(";";D13))*1
in B18 steht
=WENN(A18<=$D$14;TEIL($D$13;FINDEN(";";$D$13)+1;99)*1;0)
dies kopieren bis B32.

Der IKV der Ausgangssituation ergibt sich dann mit
=IKV(B17:B37) (D17 u. H17)

In F18:G26 werden die gewünschten Investitionen bzw. Rückflüsse eingeben.
In I17:N17 die Laufzeiten.

In H18 steht
=F18&";"&G18
kopieren bis H26

Nun selektiere H17:N26 und wähle Daten>Mehrfachoperation (bzw.Daten>Tabelle ab XL2000)
Werte aus Zeile:D14
Werte aus Spalte:D13

Die Datentabelle hat nun indirekt 2 Spaltenvariablen und eine Zeilenvariable


ÜBRIGENS:

Du kannst auch semikolongetrennt 2 oder mehr Ergebniswerte berechnen,
da im Gegensatz zu Pivot-Tabellen bei MEHRFACHOPERATION im Datenbereich
auch Strings stehen können.

Gebe dazu in H17 z.B.
=TEXT(IKV(B17:B37);"0%")&";"&TEXT(NBW(6%;B17:B37);"#.##0")
ein und Du erhälst den IKV sowie den NBW zu 6%.
Anstelle des Semikolons können natürlich auch andere Zeichen stehen
Nimmt man das Zeilenumbruchzeichen ZEICHEN(10) können die Werte untereinander angezeigt werden.




 
    zurück


 
powered by telltarget