Das grosse Archiv mit 637
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
 
Diagramme (1) ->

Ein Wasserfalldiagramm darstellen

Autor: Klaus Kühnlein
 
 
Aufgabe
Ein Stufendiagramm soll erstellt werden. Damit kann man beispielsweise eine Kontenfortschreibung visualisieren.




Lösung
von A4 bis A11 die Zahlen 1 bis 8 schreiben
von B3 bis B11 die Aenderungen als Zahlen eintragen
in C3 die Formel =C2+B3 fuer den Saldo eintragen und bis C11 kopieren
in E4 die Formel =C3-G4 fuer den unsichtbaren Stuetzbalken eintragen und bis E11 kopieren
in F3 die Formel =WENN(B3>=0;B3;0) fuer die steigenden Werte eintragen und bis F11 kopieren
in G3 die Formel =WENN(B3<0;-B3;0) fuer die fallenden Werte eintragen und bis G11 kopieren
in H4 bis H11 den Wert 1 eintragen

E4 bis G11 markieren und mit dem Diagramm-Assistenten ein gestapeltes Saeulendiagramm erzeugen
Reihe 2 gruen formatieren, dann sind alle steigenden gruen
Reihe 3 rot formatieren, dann sind alle fallenden rot
Reihe 1 Rahmen und Flaeche keine, dann sind die Stuetzbalken unsichtbar
Diagramm mit der rechten Maustaste anklicken und Datenquelle auswaehlen
Reiter Reihe und Taste Hinzufuegen und fuer Werte =Tabelle1!$C$4:$C$11 und OK-Taste
Das addiert neue Teilsaeulen, diese mit der rechten Maustaste anklicken und Diagrammtyp waehlen.
Diagrammtyp Punkt (XY) waehlen und OK-Taste
Die Linie mit der rechten Maustaste anklicken und Datenreihen formatieren.
Reiter Muster, Linie und Markierung ohne
Reiter Fehlerindikator X, Anzeige Plus, Fehlerbetrag Anpassen bei Plus: =Tabelle1!$H$4:$H$11
Fehlerindikatoren formatieren, Reiter Muster, Markierung einstellen


Erläuterung
Das beschrieben Beispiel funktioniert nur für Fälle, in denen die Werte im positiven Bereich bleiben. Können auch negative Zahlen vorkommen, wird es noch um einiges komplizierter. Die Lösung mit negativen Zahlen findest Du in diesem DOWNLOAD(22kb)
 
    zurück


 
powered by telltarget