Das grosse Archiv mit 637
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Listen/Datensätze (10) ->

Ermittlung der x letzten Werte oder Texte einer Spalte (54)
 
 
Aufgabe
Die 5 letzten Einträge einer Spalte sollen ausgegeben werden.
Der Fünftletzte soll zuerst genannt werden.

       A               B               C       
1 591  717  5  
2 693  734   
3 878  631   
4 281  690   
5 460  320   
6 268     
7 708     
8 109     
9 983     
10 853     
11 717     
12 734     
13 631     
14 690     
15 320     


Lösung
Spalte: A

In C1 steht 5
In B1 steht:
{=WENN(ZEILE(A1)>C$1;"";INDEX(A$1:A$999;KGRÖSSTE((A$1:A$999<>"")*ZEILE($1:$999);C$1+1-ZEILE(A1))))}
runterkopieren

Leerzellen dürfen vorkommen.
 
    zurück


 
powered by telltarget