Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Datum/Zeit (1) ->

Von Weihnachten abgeleitete Feiertage + 16 Bundesländer (299)

Autor: Gerhard Ehmann
 
 
Aufgabe
Folgende Feier- bzw. Gedenktage werden nicht von der Osterformel (= bewegliche Feiertage in Formel Nr. 3), sondern von Weihnachten abgeleitet:
Lösung
In A1 steht das Jahr

Volkstrauertag
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-35
Buss- u. Bettag
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-32
Totensonntag/Ewigkeitssonntag
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-28
1. Advent
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-21
2. Advent
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-14
3. Advent
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)-7
4. Advent
=DATUM(A1;12;25)-WOCHENTAG(DATUM(A1;12;25);2)

Hat nichts mit Weihnachten zu tun, ist aber beweglich. War bis 2008 von Ostern abhängig: der Muttertag ist am zweiten Sonntag im Mai - außer er fällt mit Pfingsten zusammen - dann am ersten. Das "außer" ist entfallen.

Muttertag
=DATUM(A1;5;15-WOCHENTAG(DATUM(A1;5;1);2))


alle Feiertage der 16 deutschen Bundesländer als Matrix aufgeschlüsselt
download


alle Feiertage in einer einzigen Formel
In A1 steht ein Datum; fällt dieses auf einen Feiertag, wird er angezeigt.
bzw. direkt aktuell: A1 in der Formel durch HEUTE() ersetzen.

=WENNFEHLER(INDEX({"Neujahr"."3 Könige"."Valentinstag"."Frauentag"."Pi-Tag"."1. Mai "."Friedensfest"."Mariä Himmelfahrt"." deutsche Einheit"."Reformationstag"."Allerheiligen"."Mauerfall"."Martinsgans"."Nikolausi "."Heiligabend "."Weihnachten 1"."Weihnachten 2"."Silvester"};VERGLEICH(TEXT(A1;"TTMM")*1;{101.601.1402.803.1403.105.808.1508.310.3110.111.911.1111.612.2412.2512.2612.3112};0));"")&WENN(DATUM(JAHR(A1);5;15-WOCHENTAG(DATUM(JAHR(A1);5;1);2))=A1;"Muttertag ";"")&WENNFEHLER(INDEX({"Altweiber";"Rosenmontag";"Karfreitag";"Ostersonntag";"Ostermontag";"Vatertag";"Pfingstsonntag";"Pfingstmontag";"happy cadaver"};VERGLEICH(A1-(7*RUNDEN((4&-JAHR(A1))/7+REST(19*REST(JAHR(A1);19)-7;30)*0,14;)-6);{-52;-48;-2;0;1;39;49;50;60};0));"")&WENNFEHLER(INDEX({"Volkstrauertag"."Buß-und Bettag"."Totensonntag"."1. Advent"."2. Advent"."3. Advent"."4. Advent"};VERGLEICH(A1-("24.12."&JAHR(A1))+REST(("24.12."&JAHR(A1))-1;7);{-35.-32.-28.-21.-14.-7.0};0));"")&" "


die Uhr für Weihnachtsflüchtlinge
=WENN(JETZT() < DATUM(JAHR(JETZT());12;24);"In "&WENN(AUFRUNDEN(DATUM(JAHR(JETZT());12;24)-JETZT();0)>1;AUFRUNDEN(DATUM(JAHR(JETZT());12;24)-JETZT();0)&" Tagen geht's los.";TEXT(ABRUNDEN(JETZT()+1;0)-JETZT();"h:mm")&" Stunden geht's los.");WENN(JETZT() > DATUM(JAHR(JETZT());12;27);"Es ist überstanden."; FEST((72-(DATUM(JAHR(JETZT());12;27)-JETZT())*24)/0,72;2) &" % sind geschafft; noch "&TEXT(DATUM(JAHR(JETZT());12;27)-JETZT();"[h]:mm")&" Stunden."))
 
    zurück


 
powered by telltarget