Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Zahlensysteme (16) ->

Umwandlung einer Dezimalzahl in die Zahl eines beliebigen Zahlensystems (262)
 
 
Aufgabe
Eine Dezimalzahl soll in die Zahl eines beliebigen (frei wählbaren) Zahlensystems umgewandelt werden.
Binärzahlen funktionieren bis 2^47 / alle anderen Zahlenbasen bis zur Darstellungsgrenze von Excel.


Lösung
       A               B       
1 Zahlensystem  Beispiele für 9.123  
2 2 (Binär)  10001110100011  
3 242443  
4 8 (Oktal)  21643  
5 16 (HEX)  23A3 

In A1 steht die Dezimalzahl.
In B1 steht die Zahlenbasis, auf die umgerechnet werden soll (maximal 36).

In A4 steht =A1
In A5 steht:
=GANZZAHL(A4/$B$1)

In B4 steht:
=WENN(A4=0;"";A4-GANZZAHL(A4/$B$1)*$B$1)

In C4 steht:
=WENN(B4="";"";WENN(B4>9;ZEICHEN(55+B4);B4))

A5; B4 und C4 bis Zeile 51 runterkopieren (diesen Bereich ausblenden).

das Ergebnis:
=C51&C50&C49&C48&C47&C46&C45&C44&C43&C42&C41&C40&C39&C38&C37&C36&C35&C34&C33&C32&C31&C30&C29&C28&C27&C26&C25&C24&C23&C22&C21&C20&C19&C18&C17&C16&C15&C14&C13&C12&C11&C10&C9&C8&C7&C6&C5&C4

Erläuterung

Ab Excel-2013 sind obige Handstände überflüssig mit der Winzformel:
=BASIS(A1;B1)

 
    zurück


 
powered by telltarget