Das grosse Archiv mit 630
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   GäSTEBUCH   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Mathematische Funktionen (7) ->

Runden nach einer Anzahl signifikanter Stellen (179)

Autor: Klaus Kühnlein
 
 
Aufgabe
Folgende Formel rundet eine beliebige Zahl auf eine beliebige Anzahl signifikanter Stellen.
(EXCEL rechnet mit 15 signifikanten Stellen)

       A               B               C       
1 zu rundende Zahl  Stellen  gerundet  
2 12.345,0000000  12350,0000000  
3 12.345,6700000  12345,7000000  
4 75,2350000  75,2400000  
5 1.400,2500000  1000,0000000  
6 -129.372,3748230  11  -129372,3748200 

Lösung
In A1 steht die Zahl
In B1 steht die Anzahl der Stellen

gerundete Zahl:
=RUNDEN(A1;B1-1-GANZZAHL(LOG(ABS(A1))))



 
    zurück


 
powered by telltarget