Das grosse Archiv mit 638
VBA-freien Formellösungen und Tips
 
   
 
 ÜBER UNS   NEWS   FORMELN   TIPPS   KONTAKT   FORUM   LINKS 
   
Übersicht   Zauberbuch   Rätselbuch   Sparbuch   Bücher-Downloads / Errata  
 
Zahlensysteme (16) ->

Umwandlung von Zahlensystemen ohne Add-In: Hexadezimal- in Dezimalzahl * (117)
 
 
Aufgabe
Wie der Name schon sagt.
Ersetzt die Analyse-Funktion HEXINDEZ.

       A               B       
1 2E  46  
2 BB2289CB  3.139.602.891  
3 16EC354DC  6.153.262.300  
4 C4D558FD  3.302.316.285  
5 F80B6335  4.161.495.861 


Lösung
Zahl steht in A1

Ab Excel-2013 erledigt das ohne (Einschränkungen) die Winzformel
=DEZIMAL(A1;16)
auch ümgekehrt > DEZ in HEX =DEZIMAL(A1;16)

Vorher:
{=SUMME(16^(ZEILE(INDIREKT("a1:a"&LÄNGE(A1)))-1)*(VERGLEICH(LINKS(RECHTS(0&A1;ZEILE(INDIREKT("a1:a"&LÄNGE(A1))));1);{"0";"1";"2";"3";"4";"5";"6";"7";"8";"9";"A";"B";"C";"D";"E";"F"};0)-1))}

Verkürzung von NoNet (08.08.2005):

{=SUMME((SUCHEN(TEIL(A1;ZEILE(INDIREKT("1:"&LÄNGE(A1)));1);"0123456789ABCDEF")-1)*16^(LÄNGE(A1)-ZEILE(INDIREKT("1:"&LÄNGE(A1)))))}
 
    zurück


 
powered by telltarget